Welcome to the Alfresco Builder Network

Our technical resource site is still being improved. We'd love to hear your feedback. Tell us what you think

Version compatibility

The table below shows the versions of Alfresco's backend services that have been tested with latest versions of ADF.

Our goal is to support ADF for all versions of Content Services and Process Services. However, we only test against a subset of those versions that believe to be representative. If a bug is reported for a version that we don't test against then the bug will still be fixed in the next release (ie, the fact that a version is not tested doesn't mean that it isn't supported).

Note that smoke testing implies that the product will not "go up in smoke" when used but the tests are quicker and not as thorough as with full testing.

You can find further information about released versions of ADF in the version index and the release notes.

ADF versionContent ServicesProcess Services
3.0.0Full test: v6.1.0 RC7
Smoke test: v5.2.4
Full test: v2.0.0 (latest CI pipeline build), v1.9.0
Smoke test: v1.8.1
2.6.0Full test: v6.0.0, v5.2.4
Smoke test: v5.2.3
Full test: v1.9.0
Smoke test: v1.8.1, v1.7.0, v1.6.4
2.5.0Full test: v5.2.3Full test: v1.6.4
2.4.0Full test: v5.2.3
Smoke test: v6.0.0
Full test: v1.8.1
Smoke test: v1.9.0, v1.8.0, v1.7.0, v1.6.4

Interested in trying Alfresco?

Try Now